Security warning for JavaScript and CSS file?

George2
  • Security warning for JavaScript and CSS file? George2

    I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. And I am developing using VSTS 2008 + C# + .Net 3.5 + ASP.Net + JavaScript (jQuery).

    I met with the following security warning in browser (at the top of the page in IE) when browse a page -- "An add-on for this web site failed to run. Check the security settings in Internet Options for potential conflicts." The function I developed works fine besides the security warnings. I am using IE 8. Any ideas why there is security warnings and how to resolve?

    Here is the code I added to BlueBand.master to refer the js/css files in head section. I am developing a webpart which such script files will impact (i.e. my webpart will generate a div called "tabs" which such below scripts will impact). Any security issues?

     <link type="text/css" href="_layouts/test/themes/base/ui.all.css" rel="stylesheet" />
     <script type="text/javascript" src="_layouts/test/jquery-1.3.2.js"></script>
     <script type="text/javascript" src="_layouts/test/ui/ui.core.js"></script>
     <script type="text/javascript" src="_layouts/test/ui/ui.tabs.js"></script>
     <link type="text/css" href="_layouts/test/demos.css" rel="stylesheet" />
     <script type="text/javascript">
         $(function() {
             $("#tabs").tabs();
         });
     </script>
    

  • This is probably related to ActiveX control or scripts that is not allowed to run doe to your security settings.

    You can add your website to the trusted sites list to mitigate this problem.

    More info: Internet Explorer 8 Information bar: frequently asked questions

Tags
javascript jquery security internet-explorer
Related questions and answers
  • Possible Duplicate: How to use JavaScript and CSS in a web part? I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I am developing using VSTS 2008 + C# + .Net... html> &lt;html lang="en"&gt; &lt;head> &lt;title>Test</title> &lt;link type="text/css" href="tabcontrol/themes/base/ui.all.css" rel="stylesheet" /&gt; &lt;script type="text/javascript" src="tabcontrol/jquery-1.3.2.js"&gt;&lt;/script>; &lt;script type="text/javascript"&gt; $(function() { $("#tabs").tabs(); }); &lt;/script>; &lt;/head>

  • to refer to related css/javascript files? BTW: the existing code of css/javascript/Webpart is from existing aspx code and I am migrating aspx code to a Webpart. The code works in aspx. Currently my code looks like this, &lt;link type="text/css" href="../../themes/test.css" rel="stylesheet" /&gt; &lt;script type="text/javascript" src="../../test.js"&gt;&lt;/script>; ...I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I am using publishing portal template. I am developing using VSTS 2008 + C# + .Net 3.5 + ASP.Net. And I want

  • Hello I really need help with this... , I am using Sharepoint 2007. I have the 'collect data from user' action in a workflow - which generates a custom form within the workflow folder. The form uses a DataFormWebPart which contains xsl stylesheet. It has a 'Complete Task' button as below: &lt;td>&lt;input type="button" name="btnMarkSubmited" value="Complete Task" onclick="javascript: {ddwrt...:EcmaScriptEncode($ListName),'};'))}"&gt;&lt;/input>&lt;/td> I need to add javascript within the DataFormWebPart so I can update another form field when the user clicks the 'Complete Task' button. I

  • manager. I am not in Active Directory or Windows domain environment. I have enabled permission to anonymous users for the whole SharePoint site. Any ideas what is wrong? &lt;%@ Page Language="C#" AutoEventWireup="true" %&gt; &lt;script runat="server" type="text/C#"&gt; protected void Page_Load(object sender,EventArgs e) { Response.Redirect("http://www.google.com"); } &lt;/script>; &lt...I am using SharePoint Server 2007 Enterprise with Windows Server 2003 R2 Enterprise. I am developing using VSTS 2008 + C# + .Net 3.5 + IIS 6.0. I have put a simple aspx page into layout folder

  • Regex to Parse Script Tags Marc D Anderson

    ;script type="text/javascript" language="javascript" src="/_layouts/1033/init.js?rev=qX%2BG3yl4pldKy9KbPLXf9w%3D%3D"&gt;&lt;/script>; &lt;script type="text/javascript" language="javascript" src="/_layouts/1033/core.js?rev=CNBZRdV1h3pKuA7LsMXf3w%3D%3D" defer>&lt;/script>; &lt;script type="text/javascript" language="javascript" src="/_layouts/1033/ie55up.js?rev=Ni7%2Fj2ZV%2FzCvd09XYSSWvA%3D%3D"&gt;&lt;/script>; I need to be able to get the values of language, type, src, etc. reliably. I'd appreciate help from any regex gurus out there. I think I've reached the point of diminishing

  • Hiding Left Nav user1155

    ="ms-quicklaunchheader"&gt;&lt;SharePoint:SPLinkButton id="idNavLinkViewAll" runat="server" NavigateUrl="~site/_layouts/viewlsts.aspx" Text="&lt;%$Resources:wss,quiklnch_allcontent%&gt;" accesskey...="server" NavigateUrl="~site/_layouts/recyclebin.aspx" id="v3idNavLinkRecycleBin" ImageUrl="/_layouts/images/recycbin.gif" Text="&lt;%$Resources:wss,StsDefault_RecycleBin%&gt;" PermissionsString... it does display. I put an image in there below the nav to hold the width and it does, but it does not disappear on any page with the . Any thoughts? &lt;asp:ContentPlaceHolder ID

  • I have a webpart that pops up a jquery modal on page load. The modal prompts them to answer a question using a radio button list. They select an answer and click Answer (a modal button) which calls...;script language="javascript"&gt; $(document).ready(function() { $("#dialog").dialog({ bgiframe: true, height: 300, modal: true, closeOnEscape: false, width: 400, buttons: { 'Skip': function...','')} } }); }); &lt;/script>;&lt;div id="dialog" title="Question" style="display:none"&gt;&lt;span>&lt;/span>&lt;span>What is the Capital of Massachusetts ?&lt;/span>&lt;table id

  • as the current user. &lt;xsl:if test="@MyField = $UserID"&gt; ... code here ... &lt;/xsl:if> But the compare fails because the content from the MyField is something like : &lt;span> &lt;A HREF="/sites/121579/MySite/_layouts/userdisp.aspx?ID=452"&gt;***, Stef</A> &lt;img border="0" height="1" width="3" src="/_layouts/images/blank.gif"/&gt; &lt;a href='javascript:' onclick='IMNImageOnClick();return false;' class='ms-imnlink'&gt; &lt;img name='imnmark' title='' border='0' height='12' width='12' src='/_layouts/images/blank.gif' alt

  • where I'm programmatically trying to add it using the "Upload Web Part" feature. This is the code I'm using to add the web part: function addWebPart(serverRelativeUrl) { //var webPartXml = "&lt...\"?&gt;" + "&lt;webParts>&lt;webPart xmlns=\"http://schemas.microsoft.com/WebPart/v3\"&gt;" + "&lt;metaData>" + "&lt;type name...()); } UPDATE: Based on feedback from Wictor, I tried the following: &lt;?xml version="1.0" encoding="utf-8"?&gt; &lt;webParts> &lt;webPart xmlns="http://schemas.microsoft.com/WebPart/v3"&gt; &lt

Data information