CQWP cannot find Body field in the Announcement content type

MrChrister
  • CQWP cannot find Body field in the Announcement content type MrChrister

    I can create a CQWP for the Announcement content type, but when I export the .webpart and add

    <property name="CommonViewFields" type="string">Expires,Date;Body,text</property>
    

    In my ItemStyles.xsl I have added this to show all the returned fields

    <xsl:template name="ShowXML" match="Row[@Style='ShowXML']" mode="itemstyle">
        <xsl:for-each select="@*">
            <br />
            Name: <xsl:value-of select="name()" />
            <br />Value:<xsl:value-of select="."  disable-output-escaping="yes"/>
        </xsl:for-each>
    </xsl:template>
    

    But Body always comes back blank.

    I have two site collections; one to test and one for production. The Test collection works and returns the body of the announcement, but the Production does not.

    What should I be looking for? What could I have customized?

    Our admin does not yet have the latest service pack installed, nor do I get much of anything out of them support wise.

  • instead of

    Expires,Date;Body,text

    try

    Expires,Date;Body,Note

Related questions and answers
  • ; &lt;xsl:param name="attr-type"/&gt; &lt;xsl:param name="res" select="0"/&gt; &lt;xsl:choose> &lt;xsl:when test="$currnode/following-sibling::Row"&gt..."/&gt; &lt;xsl:value-of select="sum($Rows/@Distance[.!=''])" /&gt; &lt;/xsl:template> &lt;/xsl:stylesheet> The result is: "NaN", so I figure that my XSLT is wrong. Question...:choose> &lt;xsl:when test="$currnode"&gt; &lt;xsl:call-template name="xsum"&gt; &lt;xsl:with-param name="currnode" select="$currnode/following

  • ;/table> &lt;/xsl:template> &lt;xsl:template name="dvt_1.formactions"&gt; &lt;td nowrap="nowrap" class="ms-vb"&gt; &lt;input type="button" value="Save Draft" name="btnSave... uses a DataFormWebPart which contains xsl stylesheet. It has a 'Complete Task' button as below: &lt;td>&lt;input type="button" name="btnMarkSubmited" value="Complete Task" onclick="javascript: {ddwrt..."/&gt; &lt;/xsl:template> &lt;xsl:template name="dvt_1"&gt; &lt;xsl:variable name="dvt_StyleName"&gt;RepForm3&lt;/xsl:variable> &lt;xsl:variable name="Rows" select

  • ="Microsoft.SharePoint.WebControls" xmlns:ddwrt2="urn:frontpage:internal"&gt; &lt;xsl:template match="FieldRef[@FieldType='DataLinkUrl']" mode="Note_body"&gt; &lt;xsl:param name="thisNode" select="."/&gt; &lt;xsl:variable name="url"&gt; &lt;xsl:value-of select="substring-before(substring-after(substring-after($thisNode/@*[name()=current()/@Name],';#'),';#'),';#')"/&gt; &lt;/xsl:variable> &lt;a href="{$url}"&gt;&lt;xsl:value-of select="$url"/&gt;&lt;/a> &lt;/xsl:template> &lt;/xsl:stylesheet>

  • Name = "ItemName" /&gt; &lt;HTML>&lt;![CDATA[&lt;/a>&lt;br/&gt;Thank You<br/&gt;]]&gt;&lt;/HTML> &lt;/Case> &lt;Case Value = "2"&gt...="EventType" /&gt; &lt;/Expr> &lt;Case Value = "1"&gt; &lt;HTML>New Content on Latest Events</HTML> &lt;/Case> &lt;Case Value = "2"&gt; &lt;HTML>Modified Content on Latest Events</HTML> &lt;/Case> &lt;Case Value = "4"&gt; &lt;HTML>Deleted Content on Latest Events</HTML>

  • to access "Accountable". &lt;xsl:value-of select="@Accountable" /&gt; I've seen a few posts that indicate that this was a problem pre-SP2 however my farm is already running SP2 with the August CU...; &lt;FieldRef Name="ID" /&gt; &lt;!-- Field which do not return values --&gt; &lt;FieldRef Name="Responsible" Nullable="TRUE" Type="UserMulti" /&gt; &lt;FieldRef Name="Accountable" Nullable="TRUE" Type="UserMulti" /&gt; &lt;!-- // Field which do not return values --&gt; &lt;ProjectProperty Name="Title" /&gt; &lt;/ViewFields> &lt;/View> &lt;Query>

  • and not the id) &lt;Query> &lt;Where> &lt;Eq> &lt;FieldRef Name='Relaterat_x0020_till_x0020_avtal' /&gt; &lt;Value Type='Lookup'&gt;Test avtal</Value>...' /&gt; &lt;Value Type='Lookup'&gt;1&lt;/Value> &lt;/Eq> &lt;/Where> &lt;/Query> The problem is that this SPQuery returns results only for the first 13 lookup...='" + lookupInternalName + "' LookupId=\"TRUE\" /&gt;&lt;Value Type='Lookup'&gt;" + lookupID + "&lt;/Value>&lt;/Eq>&lt;/Where>"; listViewByQuery.Query = query; this.Controls.Add(listViewByQuery

  • In a custom list there is a column / field defined as “Name (with presence)”. In my modified aspx page, I want to do an ‘xsl if’ statement to check if the value from this field is the same as the current user. &lt;xsl:if test="@MyField = $UserID"&gt; ... code here ... &lt;/xsl:if> But the compare fails because the content from the MyField is something like : &lt;span>...='javascript:' onclick='IMNImageOnClick();return false;' class='ms-imnlink'&gt; &lt;img name='imnmark' title='' border='0' height='12' width='12' src='/_layouts/images/blank.gif' alt

  • " type="radio" name="ctl00$m$g_583145bb_3463_40cc_b5ef_6f42c371f376$ctl02" value="1" /&gt;&lt;label for="ctl00_m_g_583145bb_3463_40cc_b5ef_6f42c371f376_ctl02_0"&gt;Boston</label>&lt;/td>...; &lt;td>&lt;input id="ctl00_m_g_583145bb_3463_40cc_b5ef_6f42c371f376_ctl02_2" type="radio" name="ctl00$m$g_583145bb_3463_40cc_b5ef_6f42c371f376$ctl02" value="3" /&gt;&lt;label for="ctl00_m..._g_583145bb_3463_40cc_b5ef_6f42c371f376_ctl02_3" type="radio" name="ctl00$m$g_583145bb_3463_40cc_b5ef_6f42c371f376$ctl02" value="4" /&gt;&lt;label for="ctl00_m_g_583145bb_3463_40cc_b5ef_6f42c371f376_ctl02_3"&gt

  • I have a list with an URL-field. Nothing special, just the OOTB Hyperlink-field. I want to execute a CAML-query that selects items with a certain value in the description part of the URL-field. CAML &lt;Query> &lt;Where> &lt;Contains> &lt;FieldRef Name="URL" /&gt; &lt;Value Type="URL"&gt;text</Value> &lt;/Contains> &lt;/Where> &lt;/Query> Result Only items with 'text' in de url part are selected, if a item has 'text' in the description part it is not selected. How do i select items based the description of the URL?

Data information