Unexpected Error for My Interests and Newsfeed Settings

kamleshrao
  • Unexpected Error for My Interests and Newsfeed Settings kamleshrao

    While accessing My Site -> My Interests and Newsfeed Settings, I am getting this error:

    Error 
    An unexpected error has occurred. 
    Troubleshoot issues with Microsoft SharePoint Foundation. 
    Correlation ID: ee7ff5fe-feed-472e-add8-639424410447 
    Date and Time: 4/8/2010 2:23:31 PM
    

    However the My Site -> My Colleagues option work well.

    Anybody faced this problem before?

    Environment: SP2010 Server on Windows 2008.
    I am using Administrator ID to login to the site.

    Digged the LOGs and found this:

    04/08/2010 14:33:14.55  w3wp.exe (0x0828)                           0x1AFC  SharePoint Foundation           Runtime                         tkau    Unexpected  System.Web.HttpException: **Multiple controls with the same ID 'ctl00_PlaceHolderMain_ProfileEditorValueAccountName' were found**. FindControl requires that controls have unique IDs.    at System.Web.UI.Control.FillNamedControlsTable(Control namingContainer, ControlCollection controls)     at System.Web.UI.Control.FillNamedControlsTable(Control namingContainer, ControlCollection controls)     at System.Web.UI.Control.FillNamedControlsTable(Control namingContainer, ControlCollection controls)     at System.Web.UI.Control.FillNamedControlsTable(Control namingContainer, ControlCollection controls)     at System.Web.UI.Control.FindControl(String id, Int32 pathOffset)     at Microsoft.SharePoint.Portal.WebControls.AsSeenBy.GetEffectivePrivacy(Page page)     at Microsoft.SharePoint.Portal.WebControl... 4015c593-b9b1-4141-815e-82fc55777208
    04/08/2010 14:33:14.55* w3wp.exe (0x0828)                           0x1AFC  SharePoint Foundation           Runtime                         tkau    Unexpected  ...s.MySitePublicWebPartPage.GetEffectivePrivacy(Page page)     at Microsoft.SharePoint.Portal.WebControls.ProfileUI.IsViewableByMe(ProfileSubtypeProperty prop)     at Microsoft.SharePoint.Portal.WebControls.ProfileUI.LoadProfileTable()     at Microsoft.SharePoint.Portal.WebControls.ProfileUI.LoadControl(Object sender, EventArgs e)     at System.EventHandler.Invoke(Object sender, EventArgs e)     at System.Web.UI.Control.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMai...  4015c593-b9b1-4141-815e-82fc55777208
    04/08/2010 14:33:14.55* w3wp.exe (0x0828)                           0x1AFC  SharePoint Foundation           Runtime                         tkau    Unexpected  ...n(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)   4015c593-b9b1-4141-815e-82fc55777208
    

    Update based on question from Wictor:

    No changes were made to the pages manually or through UI or SPD2010.

  • Have you made any changes to the User Profile Properties? Check if there are multiple properties named AccountName.

Tags
error my-site newsfeed
Related questions and answers
  • and it produces the same error message. I’ve googled a lot but can’t seem to get anywhere, they all say "add in the pages section" but it’s already there? Update 1 I've been looking through the SharePoint logs (yuk) and have got these entries, the last one being the actual error. 03/30/2010 14:12:54.11 w3wp.exe (0x17C4) 0x1F00 Windows SharePoint Services Topology...) at Microsoft.SharePoint.ApplicationPages.AuthenticationPage.BtnSave_Click(Object sender, EventArgs e) at System.Web.UI.WebControls.Button.OnClick(EventArgs e) at System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument

  • I am facing a strange issue now. If a page is checked out by someone all others who view this page gets an "Unexpected error" error page. After making some changes to web.config I was able to get the stack trace. Any idea how to solve this issue? This issue started recently after installing an additional language pack but I doubt whether that is the reason for the error. [NullReferenceException: Object reference not set to an instance of an object.] Microsoft.Office.Server.UserProfiles.UserProfileManager.get_m_Site() +101 Microsoft.Office.Server.UserProfiles.UserProfileManager.get

  • of my other service applications were started and configured. I then did a couple of reboots. I then used powershell to unprovision the synchronization service. I then started (provisioned... attempting to start and run the UPS Sync) and eventually fails: Error ID: 22 - The Forefront Identity Manager Service cannot connect to the SQL Database Server. The SQL Server could not be contacted..., and that the firewall is configured properly. Last, verify the connection information has been configured properly. This configuration is stored in the Windows Registry. AND Error ID: 3 - .Net

  • In one of my SharePoint apps, I am getting this warning & stacktrace over and over (with different GUIDS): since it's only one of my apps, I assume there's something in my project's code, but SPDisposeCheck returns clean, and there's nothing in the logs that point to my code. Any ideas on how I can track this down? Error I'm getting: Potentially excessive number of SPRequest objects (9) currently unreleased on thread 1. Ensure that this object or its parent (such as an SPWeb or SPSite) is being properly disposed. Allocation Id for this object

  • manager. I am not in Active Directory or Windows domain environment. I have enabled permission to anonymous users for the whole SharePoint site. Any ideas what is wrong? <%@ Page Language="C#" AutoEventWireup="true" %> <script runat="server" type="text/C#"> protected void Page_Load(object sender,EventArgs e) { Response.Redirect("http://www.google.com"); } </script> <...I am using SharePoint Server 2007 Enterprise with Windows Server 2003 R2 Enterprise. I am developing using VSTS 2008 + C# + .Net 3.5 + IIS 6.0. I have put a simple aspx page into layout folder

  • Env: OS: Win2008 R2 (running inside VirtualBox) RAM: 2GB Installed all available Windows Updates My fresh SP2010 prerequisites and installation went well. Later while running the SharePoint Product...-Failed-Step8.png Event Viewer contains this entry: Log Name: Application Source: SharePoint 2010 Products Configuration Wizard Date: 2/9/2010 6:03:01 PM Event ID: 104 Task Category: None Level: Error Keywords: Classic User: N/A Computer: SP2010 Description: Failed to create sample data. An exception of type

  • It is possible to connect the site pages with layout page in SharePoint 2010. I did, but i have a problem when i am saving the data (i.e. publish the page) it gives me the following error: Error An unexpected error has occurred. Troubleshoot issues with Microsoft SharePoint Foundation. Correlation ID: 9bc41e28-4fe1-4b4f-9e00-0e0494ef9e6e Date and Time: 7/1/2010 3:30:29 AM How do I fix this error?

  • then navigate to any other page, and then click BACK or FORWARD I get an error message that says "Webpage has expired". Note that my web.config entry is: <httpRuntime executionTimeout="43200... part and tried to reproduce the same error. The results: it doesn’t hit the breakpoint. Also, I checked the EventViewer and no errors there. Please help me out in this issue, note that my control-scope is only within the web part NOT the full page. Also, I do not want to use any AJAX-controls. Update: I was told that the only way to get rid of "Webpage has expired" error is either by: Using

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I have deployed a publishing portal. I am developing a ASP.Net web application using VSTS 2008 + C# + .Net 3.5 + ASP.Net + SharePoint Server 2007 SDK. Here is my code snippets and I got error -- "Updates are currently disallowed on GET requests". Any ideas how to fix? Microsoft.SharePoint.SPException: Updates are currently disallowed on GET requests. To allow updates on a GET, set the 'AllowUnsafeUpdates' property on SPWeb. protected void Page_Load(object sender, EventArgs e) { try

Data information