SiteData service: some methods give Access Denied

Mel Gerats
  • SiteData service: some methods give Access Denied Mel Gerats

    We recently migrated some applications from SharePoint 2007 to SharePoint 2010. The application uses the SiteData.asmx web service.

    After the migration there are Access Denied errors, withtout any additional information.

    The following sample code reproduces the problem:

    var service = new SiteData();
    service.Url = url + "_vti_bin/sitedata.asmx";
    
    string web;string site;string bucket;string list;string item;
    
    service.GetURLSegments(url + "Docs/SomeDocumentLibrary/Test/testafterupdate/2007-00152-01-E.doc", out web, out bucket, out list, out item);
    

    The point is to get the listId from the url.

    The error I get is: Server was unable to process request. ---> Access is denied.

    System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)   at ConsoleApplication1.test.SiteData.GetListCollection(_sList[]& vLists)   at ConsoleApplication1.Program.Main(String[] args)
    

    The exact same error comes back on some of the other web methods (getlistitems, getlist, getlistcollection)

    Other web metods do work fine (GetSiteUrl, GetSiteAndWeb)

    The error happens when running as a farm administrator. The same error happens running on a local development machine, which makes me think it has nothing to do with user permissions.

    Has anyone seen this error before, or managed to solve it?

    Edit:

    The error goes away when only Windows Authentication is configured. Is there a way to fully enable the old web services with claims based authentication?

    Update

    The real issue is Multiple Membership Providers not really working in a lot of situations. We have to following issues:

    • legacy web services do not fully work.
    • odata does not work. (http://localhost/_vti_bin/listdata.svc/List hangs indefinitly)
    • Livewriter can not connect to blog site
    • opening office documents in edit mode gives access denied, but they can actually be opened.

    For applications using SharePoint web services we will extend the web application and have an internal url with only Windows authentication enabled.

  • Does it consistantly fail on the same line or is it seemingly random? Do you have more than one web front end? I have seen an issue with some load balanced environments where the request is routed to a different web front end and given the access denied message.

    I like to use WebService Studio (http://code.msdn.microsoft.com/webservicestudio20) to test web service calls separate from the code implemention. This normally helps me determine if it is my code or how the web service functions.

Related questions and answers
  • times for other implementations) in this particular instance, starting the user profile synchronization service generates the following errors (these can be found in the windows logs of the server... is in the right groups with the right permissions. Thoughts? UPDATE The SQL Server now has the following error, repeatedly: Event 17806 SSPI handshake failed with error code 0x8009030c, state 14 while...) the synchronization service. The original errors are back, though BOTH the FIM services are started on the APP server. UPDATE From the ULS, this seems to be the error that is my plague. 07/09/2010 13:09

  • I have created a "Hello World" web part. When I pressed F5 in Visual Studio 2010, I got the following error. I have already got Microsoft SharePoint Foundation User Code Service started. Can anyone shine some light on this? --------------------------- Microsoft Visual Studio --------------------------- Unable to attach. Process 'SPUCWORKERPROCESS.exe' is not running on 'WIN-MP9OQOTCKB2'. Do... Application Registry Service 46e7ddc8-49af-4a7e-9eee-155f526ed509 Microsoft SharePoint Foundation User Code Service

  • I have a new SharePoint 2010 server farm that I'm trying to configure. Installation went fine. But I'm having trouble getting the user profiles to import. I've created the User Profile service application, and the two user profile services are running. However, whenever I try to create a synchronization connection to our AD servers, I'm getting the following error: "The operation was aborted because the client side timeout limit was exceeded." In the SharePoint logs, when I filter based on the correlation ID, I get the following messages: Name=Request (POST:http://poc-bi-sp:8080/_layouts

  • . The Reporting Services URL has been set within Central Administration. When I fill in the "Grant Database Access" form with a user account and click OK, the following message displays: 'A connection...On a single Windows 2008 Server I'm running SharePoint 2007 Enterprise (SP2, December 2009 CU) and SQL Server 2005 (SP3, CU 7). Authentication is NTLM. I've been trying to get SharePoint Reporting... and SharePoint (as it is impossible to only uninstall the Reporting Services component with SQL Server 2005) used the same service account for all SQL services and the same for all SharePoint services given all

  • and clicking the "Next" button, they receive an Access Denied error. Thinking that the branching may have been causing an issue, I removed it. The users can now see the whole survey at one time, but when they try to submit their answers they still received the Access Denied error. I have tried sending an access request from a test user (as prompted by the error page), but I still received the same error...I have created a simple survey with SharePoint Server 2010 with the intent of allowing all our domain users to access and complete it. I added some basic branching logic to this survey as well

  • Scenario: We have an internal application that ties Excel spreadsheets stored in a SharePoint doc lib with specific Opportunities in CRM. The user clicks on a button in the Opportunity and a Web... into it. Either way, it then opens the file in Excel. The code to open the file is some client-side script that figures out the location of the Excel file in SharePoint, sets an href variable to that URL... to them by SharePoint as read-only (so they will get the above error message). However, often they are demonstrably the only user to have accessed the document - in fact, sometimes this will happen

  • the Supporting Files tab on the List Properties dialogue box for List B. However, when I try to display the data in List B, I get the following error: “Unable to display this Web Part....” I’m guessing this has something to do with customized DispForm having some code in it that prevents it from pulling in data from List B. I’m using WSS 3.0 and SharePoint Designer 2007. Any help...I have two lists (List A and List B) that were created from the same list template. The Dispform for List A was customized (some fields were cut out and others were rearranged). The customized

  • We have an issue in accessing custom a DB from a SharePoint custom webpart. When we try to access the custom DB from SharePoint webpart we are getting the error "Login Failed for User NTAuthority..." and DB Server Instance has the same user "domain\someuser" and has permission to Custom DB. Web.config entries: <authentication mode="Windows" /> <identity impersonate="true" /> The connection string we are using is "Data Source=xxxx; Initial catalog=yyy; Integrated security=true;" We have tried with a small change in conneciontion string as well "Data Source=xxxx; Initial catalog

  • on the site collection for the forms authentication logon page to work from Office SharePoint Server. Contact your administrator to have anonymous access enabled in Central Administration and IIS. Manage...I am using SharePoint 2007 Server x64 on Windows Server 2008 x64. I create a new SharePoint web application with a new site collection at the root of the web application. I select the template "publishing portal" for the site collection. I have also enabled anonymous access. Now the basic function is fine, except that I do not know how to change the first front page (i.e. the page showed to end

Data information