can not find list control when adding a list to a web page

George2
  • can not find list control when adding a list to a web page George2

    I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I have created a list in top level site. And I want to use the list in a child site (e.g. adding the list to a page in child site by using Page --> Add Web Parts --> Browse), but can not find the list created in parent site in this way. Any ideas how to use the list (created in parent site) in a child site?

    BTW: I can use the list (created in parent site) in parent site without any issues.

  • Check out the Content Query Web Part.

Tags
list publishing-site
Related questions and answers
  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I am using Insert Data View function from SharePoint Designer 2007 to insert a list created in parent site to a child site. Now the list displays correctly. My question is, how to hide the column name (displayed at the top of list content rows) in my child site (I want to show the list rows only, no need to show the list column name)?

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I have a root web site and some child sub-web site. I am using Blueband.master and related css files (e.g. Band.css). My question is, for my parent site and child site, are they using the same master page files (including css files) or using different master page files (including css files) -- if they are using different ones, how to find which master page files (including css files) root site and child site are using? I ask this question is because I find some

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I am using SharePoint Designer 2007 to import a list to a web page by using Data View -> Insert Dataview, I find when the list is from the same site, it is ok; I find when the list from child site, there is error like (I drag the list directly to get all the content, no additional sub-filter on the list), The server returned a non-specific error when trying to get data from the data source. Check the format and content of your query and try again. If the problem

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I have two sites of the same site colleciton and I want to use Data Source Library to make site A be able to use lists defined in site B. From site A, I am using "Connect to another library" to add site B. And from Data Source Library of site A, I can see lists defined in site B. My question is how to use such lists in a page of site A? I followed the guide here, http://office.microsoft.com/en-us/sharepointdesigner/HA101191181033.aspx

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I met with strange SharePoint internal error when click some links on a web site. I have tried to use SPTraceView (http://sptraceview.codeplex.com/) to dump related logs, I find the following error logs, any ideas what is wrong? I am not sure whether in my scenario, using SPTraceView is the best way to diagnose, any better ideas to diagnose? Application Server Job failed for service instance Microsoft.Office.Server.Search.Administrator.SearchServiceInstance(xxxxxxxx-xxx GUID) Reason: access to file "C

  • Is it possible to use the Content Query web part to filter on multiple specific content types that do not have a parent/child relationship? I have a requirement to show Events (from a calendar) and Announcements (from an Announcement list) aggregated in the same area but as these come from two different branches in the content type tree, I can't do this via configuration of the web part. Would I be able to do this with a custom CAML query after exporting/re-importing the web part xml? Also I noticed the following two XML clauses in the webpart.xml file: <property name="ContentTypeName

  • to reverse the engineer the code for use on any list view. While doing so I created an error on the Reusable Content page (I believe it is called ReusableContentPicker.aspx but I am away from my VM and can't check.) and deleted the list view web part that was displaying the Reusable Content list from the page in web part maintenance mode. Not enough coffee that morning (>_<) Now when I load the page I just see the heading about adding Reusable Content but no list. Any ideas on how to get the list back on the page? Would an unghost from code work?

  • I am using SharePoint 2007 Server x64 on Windows Server 2008 x64. I create a new SharePoint web application with a new site collection at the root of the web application. I select the template "publishing portal" for the site collection. I have also enabled anonymous access. Now the basic function is fine, except that I do not know how to change the first front page (i.e. the page showed to end users who have not logged in yet) of the site. Here is a screen snapshot. Any ideas how to edit this page? Publishing home page http://i33.tinypic.com/2hex08j.png BTW: I have tried to edit

  • I'm able to use an SPDataSource to get read only data using the Select Command. But I have not been able to find a solution for adding data to a list using SPDataSource. How do I use the UpdateCommand with SPDataSource to update fields in SharePoint 2010 lists?

Data information