Error importing a data view web part

George2
  • Error importing a data view web part George2

    I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I am using SharePoint Designer 2007 to import a list to a web page by using Data View -> Insert Dataview,

    • I find when the list is from the same site, it is ok;
    • I find when the list from child site, there is error like (I drag the list directly to get all the content, no additional sub-filter on the list),

    The server returned a non-specific error when trying to get data from the data source. Check the format and content of your query and try again. If the problem persists, contact the server administrator.

    Any ideas what is wrong?

  • This is one of those wonderful errors that could be caused by many things. The first place I would look is in your ULS logs, you may be able to suss out a more definitive error message there that could point you in the right direction. I have seen this happen when permissions are not set correctly (visitor, sometimes causes this) and also when there are a lot of items in the list you are attempting to display. If you can do a little further research and let me know more about the list you are attempting to use, how many items, and also any errors that you might see in the logs, I'll be glad to research further.

  • George:

    I'm not sure how you are able to drag a list from another site into the DVWP, but that won't work. What you need to do is add a connection to the other site as follows:

    • Open the Data Source Library by clicking Data View / Manage Data Sources.
    • At the bottom of the pane, click on "Connect to another library..."
    • Add the connection using the ensuing dialogs

    Once you have done this, you can use the lists and libraries from the other site just as you would use lists and libraries in the current site. They will be listed separately under the name of the site in the Data Source Library.

    M.

Related questions and answers
  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I have created a list in top level site. And I want to use the list in a child site (e.g. adding the list to a page in child site by using Page --> Add Web Parts --> Browse), but can not find the list created in parent site in this way. Any ideas how to use the list (created in parent site) in a child site? BTW: I can use the list (created in parent site) in parent site without any issues.

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I am using Insert Data View function from SharePoint Designer 2007 to insert a list created in parent site to a child site. Now the list displays correctly. My question is, how to hide the column name (displayed at the top of list content rows) in my child site (I want to show the list rows only, no need to show the list column name)?

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I want to know how to find error logs when I met with something wrong? For example, when I am using SharePoint Designer 2007 to import a list to a web page by using Data View -> Insert Dataview, there is error message like as follows: The server returned a non-specific error when trying to get data from the data source. Check the format and content of your query and try again. If the problem persists, contact the server administrator. How to find more details logs?

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I am using publishing portal template. I am creating a list with the default "Title" column -- Title (linked to item). I want to make anonymous users to be able to view list content and also wants anonymous users to be able to click the Title link to see item details. But I find when I clicked Title link, I have to login in order to view item details. Any solutions to make anonymous user to be able to click and view Title link? thanks in advance!

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I am using SharePoint Designer 2007 to design pages. When I open the default.aspx under Pages sub-folder of a site, there are two options: Edit in Browser and Edit Page Layout. I want to know what are the differences between Edit in Browser and Edit Page Layout -- especially what is the function of Edit Page Layout, because when I select Edit Page Layout, WelcomeSplash.aspx opens in SharePoint Designer, other than default.aspx itself (very confused). thanks

  • site collections including those based on publishing templates, contentclass:STS_Web will list all sites based on publishing templates A search post-SP2 using contentclass filtyer as above will return only site collections/sites using non-publishing templates. All other content is availble e.g. documents, lists Has anyone else come across this? UPDATE 08/05/10: I have been doing some further..." returns the webs or sites respectively. UPDATE 02/06/10: As I mentioned above an upgrade to SharePoint 2010 will fix the issue (at least make the STS_Site and STS_Web results appear again

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I met with strange SharePoint internal error when click some links on a web site. I have tried to use SPTraceView (http://sptraceview.codeplex.com/) to dump related logs, I find the following error logs, any ideas what is wrong? I am not sure whether in my scenario, using SPTraceView is the best way to diagnose, any...:\Windows\system32\drivers\etc\HOSTS" is denied. BTW: when using anonymous user, no such errors. thanks in advance!

  • We recently migrated some applications from SharePoint 2007 to SharePoint 2010. The application uses the SiteData.asmx web service. After the migration there are Access Denied errors, withtout any...;string item; service.GetURLSegments(url + "Docs/SomeDocumentLibrary/Test/testafterupdate/2007-00152-01-E.doc", out web, out bucket, out list, out item); The point is to get the listId from the url. The error I get is: Server was unable to process request. ---> Access is denied. System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Access is denied

  • I am not an expert on the installation of SharePoint, but I have been trying to configure the MOSS installation on one of our DEV servers. The first problem was found when trying to set up an SSP... into this and decided to completely re-install MOSS on that box. I have tried to re-run the config wizard to hook this server up to the existing config database and to re-create the central admin site. However I now get a security exception when the config wizard is run. These are the relevant lines from the config wizards log file: 05/05/2010 09:43:45 8 INF Creating connection string for admin content db

Data information