Access to HOSTS file denied by search service

George2
  • Access to HOSTS file denied by search service George2

    I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise. I met with strange SharePoint internal error when click some links on a web site. I have tried to use SPTraceView (http://sptraceview.codeplex.com/) to dump related logs, I find the following error logs, any ideas what is wrong? I am not sure whether in my scenario, using SPTraceView is the best way to diagnose, any better ideas to diagnose?

    Application Server Job failed for service instance Microsoft.Office.Server.Search.Administrator.SearchServiceInstance(xxxxxxxx-xxx GUID) Reason: access to file "C:\Windows\system32\drivers\etc\HOSTS" is denied.

    BTW: when using anonymous user, no such errors.

    thanks in advance!

  • Google seems to be returning quite a few results on this one.

    Seems you might have to manually re-configure permissions on your HOSTS file

Related questions and answers
  • the log file and there are a lot of entries regarding stsadmin, a few exceptions (access denied) even though I am both a server administrator and a farm administrator (everything is all and the same server.... Any ideas? Edit: User Profile Synchronization Service status is 'Stopped', but when I click 'Start' it asks for a password, where the account is 'NT AUTHORITY\NETWORK SERVICE' (and can't be changed... jobs running at the time, plus I tried a reboot and got the same error message. I also try to start Forefront Identity Manager Service and it stops straight away (domain account or local system

  • After following Spence Harbar's Rational Guide to implementing SharePoint Server 2010 User Profile Synchronization (http://www.harbar.net/articles/sp2010ups.aspx) exactly (and having it work several times for other implementations) in this particular instance, starting the user profile synchronization service generates the following errors (these can be found in the windows logs of the server... 22: The Forefront Identity Manager Service cannot connect to the SQL Database Server. This error now only exists once in the logs. The User Profile Sync service is now stuck at starting rather than

  • On a single Windows 2008 Server I'm running SharePoint 2007 Enterprise (SP2, December 2009 CU) and SQL Server 2005 (SP3, CU 7). Authentication is NTLM. I've been trying to get SharePoint Reporting.... The Reporting Services URL has been set within Central Administration. When I fill in the "Grant Database Access" form with a user account and click OK, the following message displays: 'A connection to the computer cannot be established'. There is no error logged to the ULS logs or the Reporting Services logs about this. I've tried: a complete uninstall and reinstall both SQL Server

  • I got a call from a user who was trying to access the English variant of our simple portal and was getting an 'Access denied' message. As it turned out, she really wanted the German version and was happy when that worked ok. I would like to find out why she was not able to access the English variant. The error message contained no further information and the page contents for the en and de... GMT, server locale or something else. Perhaps I was looking in the wrong file) Can anyone suggest a method to get closer to the cause of this problem? Is there any way to increase the verbosity

  • We recently migrated some applications from SharePoint 2007 to SharePoint 2010. The application uses the SiteData.asmx web service. After the migration there are Access Denied errors, withtout any.... The error I get is: Server was unable to process request. ---> Access is denied. System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Access is denied.... Has anyone seen this error before, or managed to solve it? Edit: The error goes away when only Windows Authentication is configured. Is there a way to fully enable the old web services

  • I am using SharePoint 2007 Enterprise + Publishing portal template + Windows Server 2008. And I am developing using ASP.Net + C# + .Net 3.5 + VSTS 2008 on SharePoint Server 2007. I am developing... is, when a user access a page for the first time in my SharePoint site which needs authentication, if there is a special URL variable in current http session called "Identity", I want to treat the user as authenticated user and using the value of the "Identity" URL variable to be the authenticated user name of SharePoint (for example, accessing my SharePoint site by URL http://mysite/default.aspx

  • I am trying to pull data from the list.asmx web service from a console application. I am using clams based authentication, and whenever only integrated Windows Authentiation is checked everything works fine. Whenever I also check Enable Forms Based Authentication I start getting an Acccess is denied error when I try to connect to the service. I can login successfully using FBA so I don't think the problem is caused by the FBA configuration. Does anyone have any ideas to what might be causing this?

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2008 Enterprise, and I am using publishing portal template. I have created a list in top level site. And I want to use the list in a child site (e.g. adding the list to a page in child site by using Page --> Add Web Parts --> Browse), but can not find the list created in parent site in this way. Any ideas how to use the list (created in parent site) in a child site? BTW: I can use the list (created in parent site) in parent site without any issues.

  • I am using SharePoint Server 2007 Enterprise with Windows Server 2003 R2 Enterprise. I am developing using VSTS 2008 + C# + .Net 3.5 + IIS 6.0. I have put a simple aspx page into layout folder... manager. I am not in Active Directory or Windows domain environment. I have enabled permission to anonymous users for the whole SharePoint site. Any ideas what is wrong? <%@ Page Language="C#" AutoEventWireup="true" %> <script runat="server" type="text/C#"> protected void Page_Load(object sender,EventArgs e) { Response.Redirect("http://www.google.com"); } </script> <

Data information