SMB administrative Shares (C$) not accessible on a server running SharePoint - WebDAV MiniRedir reports PROPFIND not implemented

Alexey Krasheninnikov
  • SMB administrative Shares (C$) not accessible on a server running SharePoint - WebDAV MiniRedir reports PROPFIND not implemented Alexey Krasheninnikov

    Cross-posted from http://serverfault.com

    We have a SharePoint 2007 server (Windows 2003) for development which fails to provide access via SMB administrative shares like \server\c$. I can use \mywin7\c$ backwards from a terminal session on that server.

    Looking at the packets I see that the \server\share requests are handled by IIS 6 which renders http status 501 Not Implemented in response to PROPFIND verb WebDAV requests.

    PROPFIND / HTTP/1.1 Connection: Keep-Alive User-Agent: Microsoft-WebDAV-MiniRedir/6.1.7600 Depth: 0 translate: f Content-Length: 0 Host: server

    HTTP/1.1 501 Not Implemented Content-Length: 0 Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET Date: Fri, 18 Dec 2009 08:03:25 GMT

    How can I force the use of SMB over HTTP/WebDAV for such requests?

    SMB Tree Connect AndX Request, Path: \host\c$

  • Starting the "Server" service using services.msc renders UNC paths working again.

Tags
error webdav
Related questions and answers
  • I have a Silverlight 4 Beta application where I'd like to use the SharePoint object model to upload a document to a SharePoint site - should be simple enough, except an exception is thrown at: using... isn't in the IIS metabase because it's being handled by DNS. My web application has an AAM set up and a host header on the web site in IIS. I also tried running the code without using the FQDN of the site, e.g. http: //servername:4860. Permissions: The identity of the the Silverlight application pool has db_owner permissions to my content database, and is also a site collection administrator. I

  • I am using Microsoft Search Server 2008 (based on SharePoint Server 2007) + C# + .Net 3.5 + VSTS 2008 + ASP.Net to develop a web application which invokes Search Server 2008 Web Services when a button in the html page is pressed. I am using the following code to query content from Microsoft Search Server 2008. My question is how to display the search results from the DataSet retrieved? I did not find a very good sample from Google. protected void Button1_Click(object sender, EventArgs e) { //The string containing the keyword to use in the search string keywordString

  • I am trying to find the best way to accomplish the following: Move an existing share point application's content and meta databases, back them up and restore them to a different machine. In order to do this I am using the stsadm tool as follows: To backup, I use this command: stsadm -o backup -url http://devpn-004:1234 -directory c:\sharePointBackup -filename testBackup.bak -backupmethod full -percentage 10 To restore, I use this command: stsadm -o restore -url %1 -directory c:\sharePointBackup -restoremethod overwrite -percentage 10 The backup completes successfully. However

  • . The only significant thing to change on the server between yesterday and today was the installation of the Citrix Web Interface for SharePoint webparts. UPDATE: I also receive the following error when starting Central Administration from the Start Menu (Start -> Microsoft Office Server -> SharePoint 3.0 Central Administration) A failure occurred when accessing the HKEY_LOCAL_MACHINE\Software\Microsoft\Shared Tools\Web Server Extensions\12.0\WSS registry key. Repair this product by selecting it from the Add/Remove Programs menu. If I access Central Administration via a browser

  • from the server on which SharePoint is running, using the internal domain name (e.g. http://localhost:5050/site). If I view the site home page while not logged in, I can't see the webpart -- this is the correct behaviour. However, if I view the site via the public address (e.g. http://www.realaddress.co.uk:5050/site) while not logged in, I can see the webpart. (I shouldn't be able...I have a web part which I am trying to target to a specific audience (the 'Staff' audience.) I have the web part in the home page of a site that has anonymous access enabled. I have set the Target

  • Using host file Loïc Wolff

    I created an application in SharePoint, lets call it http://example.com/ and a site collection with the "Empty Site" template. Since I'm using it locally in a virtual machine in host-only mode, I had to edit my host file to add 127.0.0.1 example.com Now, whenever I access this website, I cannot click on "Site Action". All it does is add a # at the end of the URL. Since I'm in a host-only VM, i cannot change the DNS to make it work (that's the way we fixed it for a dev server).

  • of the details. I've read the documentation starting at http://msdn.microsoft.com/en-us/library/ee556429%28office.14%29.aspx. I currently have a working BDC assembly; I know it works because I can make an external content type list from it. I am currently stuck on step three: "Use Microsoft SharePoint Designer to discover the DLL and create a model". I don't see where to do this at all. Under "Data Sources"? Can I use my BDC assembly for this, or do I have to create another assembly?

  • How can you change the SharePoint 2010 Central Administration site so that it works over SSL, rather than a random port over http? Other sites on the server may also use SSL, so would use a host header to differentiate between them (e.g. admin.contoso.com for central admin, docs.contoso.com for documents etc). Edit: Can't set host headers with https in IIS, even though you can add a https... secure site, or do you also have to run 'stsadm' to tell SharePoint you have done this as well?

  • I'm having a problem with SharePoint 2010 Foundation in German. I've Windows Server 2008 R2 Enterprise Host and virtual machine with same system. In that virtual machine right after starting installer, progress bar shows up and error message is displayed 'fehler beim installieren dieses packets' which google translates to: 'error when installing this packets'. I am not german so hard to say... with that german version, and Google search says nothing about it. I've tried to use that German Sharepoint on 2ndary virtual server and it failed as well so it's not related to this particular VM (still

Data information